Crash après avoir mis K.O. certains Pokémon

1 Réponses • 98 Vues

Voici le message d'erreur que j'ai lorsque mon jeu crash après la mise à K.O. de certains Pokémon :

================================Erreur de script================================
Message :
undefined method `battle_boost' for nil:NilClass

Type : NoMethodError
Script : 01500 Alpha 24 Battle Engine (deprecated)/01700 BattleEngine/01600 BE_Interpreter.rb (PSDK)
Ligne : 204
Date : 18/10/2020 18:52:51
Game Version : 256
Logiciel : Pokémon SDK 24.87
===================================Backtraces===================================
[18] : 01500 Alpha 24 Battle Engine (deprecated)/01700 BattleEngine/01600 BE_Interpreter.rb (PSDK) | ligne 204 hp_down
[17] : 01500 Alpha 24 Battle Engine (deprecated)/01600 Scene_Battle/00700 Scene_Battle_Message_Display.rb (PSDK) | ligne 22 phase4_message_display
[16] : 01500 Alpha 24 Battle Engine (deprecated)/01600 Scene_Battle/01300 Scene_Battle_Phase_4.rb (PSDK) | ligne 333 phase4_attack
[15] : 01500 Alpha 24 Battle Engine (deprecated)/01600 Scene_Battle/01300 Scene_Battle_Phase_4.rb (PSDK) | ligne 93 update_phase4
[14] : 01500 Alpha 24 Battle Engine (deprecated)/01600 Scene_Battle/00200 Scene_Battle_Core.rb (PSDK) | ligne 371 update
[13] : 01500 Alpha 24 Battle Engine (deprecated)/01600 Scene_Battle/00200 Scene_Battle_Core.rb (PSDK) | ligne 116 main
[12] : 01500 Alpha 24 Battle Engine (deprecated)/01600 Scene_Battle/00200 Scene_Battle_Core.rb (PSDK) | ligne 113 loop
[11] : 01500 Alpha 24 Battle Engine (deprecated)/01600 Scene_Battle/00200 Scene_Battle_Core.rb (PSDK) | ligne 113 main
[10] : tools/GameLoader/Z_main.rb (PSDK) | ligne 17 <top (required)>
[9] : tools/GameLoader/3_load_extensions.rb (PSDK) | ligne 45 rgss_main
[8] : tools/GameLoader/50_load_game_uncompiled.rb (PSDK) | ligne 32 <top (required)>
[7] : /lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb (ruby) | ligne 59 require
[6] : /lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb (ruby) | ligne 59 require
[5] : ScriptLoad.rb (PSDK) | ligne 124 load_tool
[4] : tools/GameLoader/Z_load_uncompiled.rb (PSDK) | ligne 10 <top (required)>
[3] : /lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb (ruby) | ligne 59 require
[2] : /lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb (ruby) | ligne 59 require
[1] : ScriptLoad.rb (PSDK) | ligne 124 load_tool
  • : Game.rb (RMXP) | ligne 24 <main>

===================================Fin du log===================================

There was an error while thanking
Thanking...