[Résolu][PSDK 24.86]game --util=update_db_symbol ne fonctionne pas

4 Réponses • 64 Vues

Zenos

Mappeur

Bonsoir

Lorsque que j'utilise la commande "game --util=update_db_symbol", une erreur s'affiche :

An error occured during Utility loading...
Error type : ArgumentError
Error message : wrong number of arguments (given 1, expected 0)
D:/PDimension/plugins/update_db_symbol.rb:46:in `name'
D:/PDimension/plugins/update_db_symbol.rb:46:in `block in <top (required)>'
D:/PDimension/plugins/update_db_symbol.rb:45:in `each'
D:/PDimension/plugins/update_db_symbol.rb:45:in `each_with_index'
D:/PDimension/plugins/update_db_symbol.rb:45:in `<top (required)>'
D:/PDimension/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require'
D:/PDimension/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require'
D:/PDimension/pokemonsdk/scripts/tools/GameLoader/50_load_game_uncompiled.rb:20:in `block in <top (required)>'
D:/PDimension/pokemonsdk/scripts/tools/GameLoader/50_load_game_uncompiled.rb:16:in `each'
D:/PDimension/pokemonsdk/scripts/tools/GameLoader/50_load_game_uncompiled.rb:16:in `<top (required)>'
D:/PDimension/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require'
D:/PDimension/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require'
D:/PDimension/pokemonsdk/scripts/ScriptLoad.rb:124:in `load_tool'
D:/PDimension/pokemonsdk/scripts/tools/GameLoader/Z_load_uncompiled.rb:10:in `<top (required)>'
D:/PDimension/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require'
D:/PDimension/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require'
D:/PDimension/pokemonsdk/scripts/ScriptLoad.rb:124:in `load_tool'
Game.rb:24:in `<main>'

Merci pour votre lecture

« Modifié: 15 septembre 2020, 23:12:48 par Zenos »

Bug Résolu

Nuri Yuri

HostMaster

Vérifie que ton dossier plugins est à jour par rapport à celui-ci : https://gitlab.com/pokemonsdk/plugins
ln(yo) = <3

Zenos

Mappeur

Voici ce que j'ai dans mon .cmd, je ne trouve pas où les .yml sont mit. Je supposais que c'etait dans Data/PSDK, mais rien en vu

D:\PDimension>Game --util=update_db_symbol
PSDK Version : 0.0.24.84
Loading Game...
Script Index : pokemonsdk/scripts/script_index.txt
Loading scripts...
D:/PDimension/scripts/00055 IntroMap.rb:1: warning: already initialized constant Scene_Title::INTRO_MOVIE_MAP_ID
D:/PDimension/pokemonsdk/scripts/01400 GamePlay/00100 Scene_Title.rb:4: warning: previous definition of INTRO_MOVIE_MAP_ID was here
D:/PDimension/scripts/25000 Objets_combat.rb:3: warning: already initialized constant PFM::IA::ItemHealingHP
D:/PDimension/pokemonsdk/scripts/01200 PFM/00200 Helpers/02900 IA.rb:301: warning: previous definition of ItemHealingHP was here
D:/PDimension/scripts/25001 CorrecShader.rb:3: warning: already initialized constant LiteRGSS::Shader::FALLBACK_SHADER
D:/PDimension/pokemonsdk/scripts/00000 Dependencies/00400 Patch_Ajouts_LiteRGSS/01200 Shader.rb:3: warning: previous definition of FALLBACK_SHADER was here
D:/PDimension/scripts/25001 CorrecShader.rb:36: warning: already initialized constant LiteRGSS::Shader::GeneralColorSprite
D:/PDimension/pokemonsdk/scripts/00000 Dependencies/00400 Patch_Ajouts_LiteRGSS/01200 Shader.rb:36: warning: previous definition of GeneralColorSprite was here
Appuyez sur une touche pour continuer...
Time to boot game : 22.621276s

PS : D'ailleurs j'en profite pour demander si y'a moyen de retirer les messages qui disent qu'un script était anciennement présent :d

Nuri Yuri

HostMaster

ça a marché, si tu veux les voir dans les yml il va falloir lancer la commande game --util=convert
ln(yo) = <3

Zenos

Mappeur

Super, ça fonctionne ! Merci :D

There was an error while thanking
Thanking...