Bug World Map [PSP_0.9.2]

10 Réponses • 91 Vues

Col03

Mappeur

Ma World Map est finie et "scriptée" mais lorsque j'ouvre ce qui doit être la WorldMap en testant mon jeu :



C'est la map d'une ville qui s'ouvre (Bonaugure ici) comme si c'était ma worldmap (lorsque le viseur de sélection navigue sur les événements des panneaux s'ouvre la boite où le nom d'une ville/route doit apparaître :


Merci d'avance pour votre réponse :)
Une signature...

Bug Résolu Bug

Leikt

Programmeur

Fais voir ton event de map au mur et ton panneau.

Col03

Mappeur

Pour le panneau c'est juste pour illustrer le fait que ma map de ma ville agit comme si c'était ma WorldMap.
Voilà le screen de mon event :


Screens de mon paramétrage pour la WM :

Une signature...
Est-ce que tu as modifié le script Config_Panel en mettant l'ID de ta map de carte du monde ?

Col03

Mappeur

Ah ! Je pense que le problème vient de là ! Je suis pas du tout spécialisé dans le script ma MAP où j'ai la carte n'est pas celle d'origine j'ai dû oublier de changer, merci :p, quelle est la ligne pour la WorldMap ?

EDIT : J'ai essayé de changer ça (en mettant l'id de ma map) mais ça ne fonctionne plus :

« Modifié: 11 juillet 2019, 21:39:27 par Col03 »

Une signature...
Déjà, reviens en arrière, ce n'est pas le bon script :p

Le Config Panel est un peu au-dessus du script Game_Map.

Je n'ai pas le script sous les yeux, par contre (je suis au travail).
Mais de mémoire, c'est à un endroit où il y a marqué "_WMAP" ou un truc comme ça. D'après le manuel, c'est la variable numéro 6 (http://krosk.free.fr/manuel/manuel.htm#C21b) du coup, tu dois aussi trouver un "$game_variables[6]".
Du coup, il suffirait de changer le "$game_variables[6] = XX" par "$game_variables[6] = Id_de_ta_world_map".
(Aussi, il me semble qu'il faut que ta map soit nommée "Carte du monde" sinon, ça marche pas).

Tout ça, je le dis de mémoire, donc ce sera peut-être pas exactement ça ><

Col03

Mappeur

Merci pour ta réponse, j'ai été consulté le manuel (je l'avais oublié...) donc j'ai fait ça :

Donc normalement ça devrait fonctionner. Maintenant je rencontre un problème, je m'explique : Je ne trouvais plus de solution alors j'ai transférer ma WorldMap sur ma map de Bonaugure (ID: 10) puis ça ne fonctionnait pas donc j'ai supprimé la map de Bonaugure et je l'ai remplacée par une copie (ID:72). Et maintenant j'ai des erreurs (dont les screens sont dans ma précédente réponse).


Une signature...

Rey

Modérateur

T'as exactement le même message d'erreur qu'avant en fait. Retourne sur le script Game_Map, ligne 12, et remplace ton "59" par "%03d" comme c'était initialement. Si y'avait ça, c'est pas par hasard...

« Modifié: 12 juillet 2019, 13:26:27 par Rey »

Col03

Mappeur

J'ai tout remis comme cela était initialement, mais toujours un problème, le problème c'est que j'ai nul part le "Data/map  59" j'ai jamais remplacé par 59, je ne comprends pas... (Initialement c'était Data/map%10.rxdata"




EDIT : J'ai copier la même ligne que dans la version PSP normale et ça re fonctionne pour l'instant je peux re-accéder au jeu !
Pour ce qui est de la carte, malgré avoir renommer ma World Map "Carte du monde" et avoir fait la manip' qu'on m'a dit, j'ai toujours un soucis :

« Modifié: 12 juillet 2019, 15:17:14 par Col03 »

Une signature...
En fait il suffit de mettre ta variable 6 au numéro de ta Worldmap (dans la scène d'intro par exemple), pas besoin de toucher aux scripts directement parce que comme tu as pu le constater ça fait tout planter quand tu ne sais pas ce que tu fais (et c'était %03d et pas %10d).

Col03

Mappeur

Merci ça fonctionne enfin ! Merci à vous tous !
Une signature...

There was an error while thanking
Thanking...