Updating to .25

12 Replies • 966 Views

Hi, I've PSDK to  .25 from .24. I followed the video, but this error message came up.

================================Erreur de script================================
Message :
superclass mismatch for class NameInput

Type : TypeError
Script : 00101_WindowName.rb (user)
Ligne : 19
Date : 17/07/2021 02:37:12
Game Version : 256
Logiciel : Pokémon SDK 25.0
===================================Backtraces===================================
[17] : 00101_WindowName.rb (user) | ligne 19 <module:GamePlay>
[16] : 00101_WindowName.rb (user) | ligne 18 <top (required)>
[15] : <internal:/lib/ruby/3.0.0/rubygems/core_ext/kernel_require.rb> (ruby) | ligne 85 require
[14] : <internal:/lib/ruby/3.0.0/rubygems/core_ext/kernel_require.rb> (ruby) | ligne 85 require
[13] : ScriptLoad.rb (PSDK) | ligne 48 load_scripts
[12] : ScriptLoad.rb (PSDK) | ligne 46 each
[11] : ScriptLoad.rb (PSDK) | ligne 46 load_scripts
[10] : ScriptLoad.rb (PSDK) | ligne 37 load_vscode_scripts
[9] : ScriptLoad.rb (PSDK) | ligne 29 start
[8] : tools/GameLoader/50_load_game_uncompiled.rb (PSDK) | ligne 7 <top (required)>
[7] : <internal:/lib/ruby/3.0.0/rubygems/core_ext/kernel_require.rb> (ruby) | ligne 85 require
[6] : <internal:/lib/ruby/3.0.0/rubygems/core_ext/kernel_require.rb> (ruby) | ligne 85 require
[5] : ScriptLoad.rb (PSDK) | ligne 128 load_tool
[4] : tools/GameLoader/Z_load_uncompiled.rb (PSDK) | ligne 10 <top (required)>
[3] : <internal:/lib/ruby/3.0.0/rubygems/core_ext/kernel_require.rb> (ruby) | ligne 85 require
[2] : <internal:/lib/ruby/3.0.0/rubygems/core_ext/kernel_require.rb> (ruby) | ligne 85 require
[1] : ScriptLoad.rb (PSDK) | ligne 128 load_tool
  • : Game.rb (RMXP) | ligne 8 <main>

===================================Fin du log===================================

Nuri Yuri

HostMaster

Maybe you should post the script you're using but I think you'll have to remove the < Something after NameInput.
ln(yo) = <3
Maybe you should post the script you're using but I think you'll have to remove the < Something after NameInput.

These are the scripts I'm using
And also these.
And these. That's all the scripts I'm using.

Nuri Yuri

HostMaster

Ok, first fixed script in the download. Please tell me if there's any other bug (send the log) so I fix the other one (it's hard to download 1 by 1 ^^')
ln(yo) = <3
Ok, first fixed script in the download. Please tell me if there's any other bug (send the log) so I fix the other one (it's hard to download 1 by 1 ^^')

It still didn't work. I've attached a zip containing all the script and the error log.

Nuri Yuri

HostMaster

Thanks a lot. There's a new way to do the Intro Movie, you can remove the script for that and change the file Data/configs/scene_title_config.yml there's a value for that :)
ln(yo) = <3
Thanks a lot. There's a new way to do the Intro Movie, you can remove the script for that and change the file Data/configs/scene_title_config.yml there's a value for that :)

I removed it, but it still didn't work. This is my scene_title_config.yml

Nuri Yuri

HostMaster

I've spotted few bugs, one is due to 00114_texture.rb (need to disable) and another bug I don't know why ^^'

I'm on it
ln(yo) = <3
I've spotted few bugs, one is due to 00114_texture.rb (need to disable) and another bug I don't know why ^^'

I'm on it

I think it's the Name_frame script.
I've spotted few bugs, one is due to 00114_texture.rb (need to disable) and another bug I don't know why ^^'

I'm on it

And also Text Shadow

Nuri Yuri

HostMaster

I figured out the bug with Text Shadow.
The issue is that I don't know what you wanted to do with it because the constant name is wrong. I have DEFAULT_OUTLINE_SIZE but it's doing a bad result ^^

The script content should be this:
module LiteRGSS
  class Text
    module Util
      remove_const :DEFAULT_OUTLINE_SIZE
      DEFAULT_OUTLINE_SIZE = 1
    end
  end
end
ln(yo) = <3

There was an error while thanking
Thanking...